End of support Joomla! 2.5

We have stopped supporting version 2.5 of Joomla! on version 3.9.1 (changelog), but if you would like to install it (not recommended) on a very old version of Joomla! you can download the limited edition.

Download v3.9.1 (Joomla! 2.5 compatible)

Still need help? Contact Us Contact Us